1. i bought this game thru gog and its been good so far but lately it ha been having random bugs like for example jumping out off no where and landing across the map or random glitches with the equipment as well so i have deleted the game. i dont care about the refund i just would like this game to run smoothly we are living in 2022 to be having this simple games fixes anyone else has them random glitches or is it just me? on to the next game hope i dont have keep deleting my games

  2. I had the same problem and struggled for ages until I tried save, quit and restart. Then I was able to accept the rads and continue the game. Hope that helps.

  3. Has the holster N/D bug been fixed? I tried to remap it in the Steam version and it gives me the N/D error. No matter what key I want to use.

  4. (PS5 user) i can't get to flip the switch on the Volga Map / Small Island with the Generator. The generator is turned on and running, but somehow I can't flip the switch. When pressing Square, the character tries to open the door instead. As if there's no action available on this switch.

  5. So wanted to ask about an issue for a friend. He is playing Exodus on PC [stand edition, not enhanced if that matters]. Now he has this weird "curse" I'll call it, where he ALWAYS gets extremely rare or obscure bugs that nobody else gets in almost every game he plays. Like I'm not even kidding, some bugs he's had I can't even find information online about and it's like he's the only person to ever play the game that got said bug.

  6. I am having issues with the boat at the doc getting stuck as soon as i load the chapter for the church and i cant unstuck it no matter what i do

  7. i'm in a death loop check point save where my gas mask/hud is gone running around in NVGs gasping till i die in the swamp before the church lol

  8. I just found an out of bounds glitch, but I am not sure what triggered it and did not try to replicate it. It happenned right at the beggining of the game, I was shot and left to die, find my way back to the bad guys base and an old dude is helping me. After I find Anna, in the next room (where a guy explains about the radio being dead silent) he was talking, I was walking around and checking what I could press E on, and next thing I know I am outside the building. I could hear them, Anna said that there were two npcs coming my way (that I should kill/avoid) but since I glitched outside before I should, none of them spawned, I tried to walk around and could not interact with the building Anna was talking from, then I decided to re-load the game and the bug did not happen again. If any more details are needed let me know. I play on PC, Ryzen 5 2600 with RTX 2070.

  9. PS4 The game crashed 4 times so far (blue screen and all) at the Volga level. The first one corrupted my save file and I had to restore to a backup save, the rest I just loaded my last quicksave. Every time it happened just as I was being attacked by a mutant. It doesn't happen every time I get attacked by a mutant though

  10. The railcar disappeared completely after I got out of the fish-factory place. I went ahead to clear the passenger car full of bandits , and when I came back, the railcar was gone. This is gamebreaking and hell no im not gonna replay The Volga, which would take like 3-4 more hours. I’m just gonna hang up the game.

  11. Yo, the same thing happened to me after I pulled the first lever to adjust its path! I was super annoyed, but went ahead and cleared out the depot where the bandits are guarding the passenger car thinking that maybe that would cause it to reappear.

  12. On ps4 During railcar mission I was able to get over to the railcar before spinning the concrete tube right before it. I got to it pretty easily so I stupidly assumed it was intentional, assuming the railcar exited the other way or something. I got in, started it, then realized I couldn't get out, so I went back and spun the tube and opened the door. Smooth sailing until I got to the track switch and found that no matter how many times I pulled the lever, the track wouldn't switch. The sign would, but the track wouldn't. I reloaded and did everything in the proper order and it was resolved

  13. PlayStation 4 user. Been wanting to change my launguage to Russian and have subtitles on English because I don’t speak Russian but I hear it makes it better, however my subtitles are stuck on Yermak: only by standing together something something and Radio: something. Exit to main menu, the words are still there. Restart app and ps4, bug is still there.

  14. So I am capturing the tugboat and I guess it gave me a checkpoint as a mantled onto the boat from the lower section, on the corner opposite from the generator switch. I died and it has reset me there and I can't move, I can't jump, if I crouch I can't stand up. I can look around and shoot, I am just simply stuck. It's also the last mission of the chapter so I'm not going to be playing the game if the "workaround" is to reset the entire chapter after I've put over almost 2 whole days into the game already (46 hours).

  15. Xbox S user, the game is full of bugs, which is quite a problem. The freezing is not even the biggest issue, but the enemies can’t see me for a while now, and I can’t even hurt them. When they see me and attack me I can’t kill them, even though I put all my bullets in their heads.

  16. Pretty much have the same issue here. I also noticed that they don't notice me, that all my guns but the Tikhar and throwable do zero damage, and that the melee no longer does damage too. I'm reinstalling now to see if that will help.

  17. I was literally playing the game 10 minutes ago in PC using Epic Games and just entered Caspian area. After leaving the train i can't change guns, cant interact with objects and doors, can't reload, can't use the gas mask so i always die when storming the building when Artyom first gets the car. Basically i can only walk,run Holst, shoot and aim. After dying and using the quick load or if i save mid game in Caspian Artyom's arms is gone NOW i can't even see the gun. I tried everything. start the whole chapter, played the Yamantau carnivores again, changed my settings including DX12, defaulted all key bindings, checked key bindings, verified game files. The only thing i haven't done is deleting the game and downloading it again because im not downloading a 50+ gb again, i just downloaded the game yesterday. I played this game and finished it before im basically re-playing Metro Exodus, i have never encountered a game breaking glitch before in this game.

  18. PC version, latest epic store build. In the Caspian sea the mission where I need to get fuel for the train does not progress any further, Damir is at the usual location but he will not speak.

  19. PC version, latest epic store build. Volga: After getting the railcar the swtich that im required to pull to change tracks is missing. This is a game breaking bug because now I literally cannot further progress in the game.

  20. You looked on the right side? There is a lever instead of how it worked in last light with shooting the yellow signs.

  21. I'm having the same problem. Freezes after I shoot a humanimal near the thug base that you encounter.

  22. I'm having the same problem, is it during the last fight of the Caspian sea area? Sorry for being vauge I'm not sure how to tag spoilers on my phone.

  23. There is a minor visual bug with a wrecked boat on the westernmost part of the Volga map, near the two small islands. The boat's steering wheel is misplaced and clipping into the floor.

  24. Xbox one user, dead enemy is stuck on screen blocking view. Restarted the game and have re loaded and the enemy is still there, also can’t progress through the Volga mission as the row boat alternates from flying through the air to sailing upside down underwater. Exiting the boat results in me standing on top of the boat while it’s upside down on the boat. Re loading doesn’t fix and neither does restarting

  25. Playing on PS4, after light house mission I’m driving to meet Anna and. Was attacked enroute by the flying demon which knocked me out of the van. I got back in the van, but now can’t get out. I can only accelerate, brake, reverse and turn headlights on/off. I can’t progress any further. The game auto saved and I can’t go back farther. Any idea what I can do? I tried to get the demon to pick me up again, but it just rocks the van.

  26. Has the invisible character model glitch been patched yet for Xbox 1? I want to keep playing but I dont want to replay the whole Caspian level just for the same glitch to persist.

  27. So I'm playing on Xbox, and ive completed most of the Caspian storyline and got to the part where I woke up in the middle of a firefight. Well when I finished the firefight Miller started talking and my game crashed. I loaded it back up and no Miller won't talk, I've waited like 10 minutes and noone is doing anything but standing still and looking around. I think the crash messed with the que to start Miller talking, does anyone know how I can fix it other than redoing the whole chapter?

  28. PC HDR and Tessalation keep crashing my game. The NPCs seem to have laser accurate shooting skills from very far distances.

  29. Ps4: in Taigia after you see the large bear chase the wolves, when you proceed to the next marker at a broken water logged see end, there is a cave to the left. There's a corpse and journal, when you leave a scripted wolf attack happens, but unless you're at high health it's impossible to kill the wolf or progress further because the QTE damages and kills you. But the only way out is to repeatedly press square (even when you see Artyom stab the wolf and hear the sound effects he dies).

  30. At the end of the caspain sea trying to get the fuel tank, I'm in the beggining part in the sewer, and when I load into the game I just straight up crash and I can't progress! Tried 8 times crash Everytime.

  31. Playing on xbox... Everytime I shoot whilst looking through 4x scope, the game freaks out and I have to restart

  32. PS4. Approached the oil rig gate early at Caspian Sea. Enemies start throwing grenades. When running away grenades fly at me like rockets from a ridiculous distance away.

  33. I believe that's just a feature. You aren't supposed to go there in the beginning, so you just get killed by the game if you do. Just visit the other parts of the map first and progress the story. Eventually you will visit that place. I visited the other fortress in the northwest too early and also got killed with no way to win.

  34. Read my recent post. Deep Silver just hit me back with an email stating there are no known bugs in the game 😂

  35. It seems to me that some textures in the Caspian bunker are bugged, I can see some weird horizontal lines in the textures. RTX 2070 and latest drivers, DX12 + RT on high.

  36. Hi im on xbox 0ne x and I have a bug where i cant use the x button to reload, loot, or interact with anything. Edit: I've tried dying, reloading a recent save, falling into water, fighting off a mutant, trying to activate a cutscene nothing is working.

  37. PS4. On the rowing boat part of the dead city level the boat stops and will not move either forwards or backwards. This happens regardless of whether I clear the side room and only resolves occasionaly when I loop back around. This continues after quicksaves and the boat is now stuck in the tunnel. Without resolving this I cannot finish the game, anyone know how to fix?

  38. PC (Steam). So, I'm on NG+ with the bad weather option enabled, and for some reason all sandstorms in the Caspian Sea essentially turn even the darkest nights into broad daylight. Despite how I can't see anything, I'm perfectly visible no matter where I am. I guess sandstorm + full moon = broad daylight, apparently.

  39. Xbox one. So in the latest update I've encounted a glitch or bug I'm not really sure what it is but since the "New Game +" was added I have been using several of the new features including more frequent storms, anyway I had finally gotten to the caspian sea and played for a bit and really enjoyed it up until leaving the caspian sea and all through that last mission I encounted said problem with the sandstorm and all throughout the mission it wouldn't go away.

  40. Ps4 Bug: Game wont register the square button at all. Occurred: After i jumped down to save anna when she took off from the train by herself into the old bunker. Additional Comments: It wont let me grab my thrown knifes or let me advance with the quest because i cant huddle on the wall to get to the switch.

  41. Also i forgot to add, it lets me pump my air bb gun, and use my lighter. It just wont let me react to environmental actions. Update: I restarted the chapter and so far it fixed it, ill do another update when i get close to where it fucked.

  42. Same problem - I even tried loading the save game across to another PC entirely and it didn't make any difference. I then tried starting from the previous section ?Yamanto? or whatever its called which makes it overwrite your save game and still it dies when i get to the Baron. Sometimes it loads up the very start and you hear a voice (Anna maybe) right before it locks up and dumps the crash file. No reply from Deep Silver yet. Playing on pc - Win10.

  43. After patch, on Xbox one X, non new game+. On Caspian, in cracked ship that houses slaves (central area of map between sniper crane and the baron compound). During 2nd room, lights will switch on when reloading a save in which panel was flipped off. Must return to panel to switch lights back on then off again. Difficult to do if you have the man on the cross walk beneath the light.

  44. PC - After the patch flashlight is still not charging/working in later level in Novosibirsk (bug starts after the spider level in the Forest).

  45. Xbox One here - just yesterday the game updated (2gb) and now my weapons won't kill an enemy - they fire and blood comes out of the enemy but I can't kill them - all was working fine before the update

  46. Experiencing a stealth breaking bug in which NVGs act like the flashlight. If I'm hidden in darkness, with my bracer indicator light off, and I activate the NVGs, they act like the flashlight, ie. they make me detectable by enemies even when I'm in complete darkness. My bracer light also turns on and off when applying and removing the NVGs, indicating that I am visible just when turning them on. I got through the Volga area without being affected by this bug, but it seemed to have popped up after that in the Yamantau area and is now present in Caspian area as well. I am putting down the game for now because this makes it unplayable for me.

  47. First Metro game and threw 10 hours into this bitch collecting everything and listening to the story so I'm pretty dissapointed.

  48. PS4 Pro: Near the end of the caspian mission when scavenging the airfield, A Demon picked me up and dropped me where Artyom clips through a building and I find out that all the enemies can’t detect me and now all of them are invincible as well, they only take damage from throwing knives as if its stealth. It even transferred over into the Taiga as well and it’s completely game breaking.

  49. 3-21-19 xbox one x games still freezes I've uninstalled and installed back same issue but still no fixes smh then in the train car when I get the part for the train car my weapons disappear and I can't even get off the train.

  50. PS4 Pro, playing on Ranger difficulty and just got to the Dead Sea. I noticed a bug in the previous level during the final battle where my gun would get stuck while aiming down the sites. Only way to get rid of it was to switch weapons and run, but I somehow beat it. Back to the Dead Sea, all seemed well until the part in the beginning where you switch seats to drive the van and it only goes in reverse...I can't turn it, get out, or go forward. I reload the save and it does the same thing. I will reload the chapter when I get home and try that, but I'm dead in the water if it does it again...are they still working on patches for consoles?

  51. I have a problem where my filters wont work after i fight gorilla in novosibirsk and i have to turn the generator on. I choke to death everytime, i tried changing my filter even tho i have 13 minutes, tho it doesnt work, i choke to death everytime

  52. Currently stuck on the winter level, last check point is of me choking, can't get to anywhere with fresh air and putting on my gas mask has no effect. Fully repaired gas mask and filters available. My last quick save was of a few days ago...

  53. PS4, the same Caspian big with Damir at the caves others have mentioned. He will not come down to boost me up. Cannot progress, and since the game is allegedly open world-esque I put 6 hours into looking around and looting everything. Tried the fix where you look at him to get him to warp over for close to 15 min. Restarted system twice. No luck. Not willing to restart chapter as I have limited play time due to family responsibilities and a backlog of games. Guess I'll play those after I warn the two friends I recommended the game to yesterday not to waste their money like I did. Such a shame to end my Metro experience like this.

  54. I’m on ps4 pro, in The Volga level and the boat gets stuck at the first dock you get to before you head to the church, I’ve reloaded the game and restarted it a bunch and restarted the level as well

  55. Xbox one: a playing railcar mission. Trying to do a pacifist run but after knocking out all of the bandits in and around the building the stealth kill/knockout prompt no longer appears when I try to take out the two bandits on the bridge at the front of the bandit camp. Tried reloading both save and checkpoint with no luck

  56. PS4: went to eject disc and it failed to release the disc while acting as if it had been ejected already. Went to put in rest mode and system crashed completely. Upon restart, it request a crash report to be sent. System has never done that before with any other game and am kind of nervous to try to replicate it.

  57. PS4 User: my game is stuck trying to 'download additional content' and won't load. Was working fine up until the end of the Volga chapter

  58. PS4 user. I'm in Volga, I'm at the bandit camp you pass through once you've obtained the railcar. The option to knock out or enemies wont appear making it extremely difficult to go through the playthrough non lethal. Someone always finds a body. It seems theres 3 enemies here so far it will not let me knock out and I cant open the gate while they're still awake.

  59. XBOX ONE user: When I started a new game (I played before, but decided to play again) and decided to find a compass, but I did not find it in the place where it should be

  60. I am having a game breaking bug in chapter caspian, I had to restart the whole chapter to solve the issue.

  61. I'm having an issue with my graphics turning pink toned with some green patches when turn on RTX on with DLSS enabled. Can't find any solutions to it. (PC)

  62. I have the exact same issue, I've tried every configuration, but as soon as I turn RTX on, shadows and some other stuff turn pink and green. (RTX 2060)

  63. On Caspian, and it appears to be in Taiga as well, there is a massive visual glitch in the sky that can best be described as the image they use for the skybox is displayed individually as a massive panel that sticks out like a sore thumb. This has affected the Caspian to where at night, I have a hard time telling if it is night because of said panel. So far I’ve only seen a single post about this here on reddit and a couple videos.

  64. Pc user, enemies on the Tug boat infiltration mission can see me through any wall as long as they're looking in my direction. making it impossible to stealth through to the captain.

  65. encoutered a bug after reloading quick save on xbox. i reloaded my old save which was roughly an hour of gameplay back and reloaded on an invisible boat that still had collision but the real bug came later when i found out i couldn't interact with anything in the world the area i was in was right before the whale monster comps the boat and i couldn't activate the cutscene or whatever because i cnt get in the boat and i went to the train from the opposite end because i had to make my way all the wY around to get back. please help i cant even loot or anything i can only use everything given such as gasmask weapons backpack etc but no interactables in the world. will update progress on attempted fixes: reloading again doesn't do anything, closing the game does nothing, restarting xbox does nothing, taking the disc out playing another game does nothing. im at a loss

  66. Ps4 user. Can't seem to find much on it but when I'm hiding from a camp of bandits that are looking for me, i can't seem to sneak up and knock them out. The prompt just doesn't show up and i end up getting spotted and killed immediately.

  67. I'm having the same issue, it's so frustrating! The bandit camp I'm having this issue at is at the southeast corner on Volga. It's the only camp so far I've experienced this glitch. Glad to know I'm not the only one.

  68. PC user:In the Caspian dessert when going in the principal mission on the tower throgh the cave,that part is not loaded and you can see throgh the map.Any idea on how to fix it?

  69. Same problem here, I know where the next point of the main story is but I haven't been able to get there, once you reach there the story continues or is all fucked up? Have you find a way to fix it?

  70. I just loaded a quick save which put put me hours and hours ago into my game. It then auto saved in the same place, so now I've lost a day's worth of day.

  71. Ps4 the bug I have gotten myself into is I cant access any of the workbench at all like i went to each one of them after i got back from the church attack so early game and I seem to still not be able to use it after a chapter either I thought re-loading would solve but it didnt I would attempt restarting but it would be the fourth time restarting since I seem to always find myself getting stuck on a branch when it autosave

  72. PC user . Boat stuck on submerged fence on way to the rail terminal in the lair been stuk for over a week now

  73. PS4 user. I just got the train trolley from the hangar with the big fish and just went through that first bandit barricade. After that I went back to the checkpoint since I messed up and it loads me to being stuck inside the first barricade. The trolley can't move in either direction and when I got out of the trolley, Artyom glitched and got stuck part way inside the trolley since he was forced into it by the barricade.

  74. PS4 User. Am stuck in the communications bunker in The Caspian. Have found control room and opened the door to leave the dungeon and hear a dialogue about having to turn the lights out to divert power to the lift. Then head back through the control centre to the lift and nothing happens. Was confused so read a walk through and returning to the lift is supposed to trigger a bug attack. This does not happen, the lift doors are sealed shut so I am effectively stuck in the bunker.

  75. hey. I have an interesting problem. When I was driving in metro exodus I took the wrong turn and ran down a cliff side outside of the map but I didn’t completely fall to my death. It autosaved there and i accidentally pressed quick save as well. No idea how to get Back up now. Please help.

  76. PS4 user. Console refuses to recognize disc. Other game discs and movies (Blu Ray and DVD) work fine. At launch had a few problems with this but after restarting console and/or ejecting disc, would read and play without any problems. Went to play today and my PS does not even pretend to recognize disc. Thoughts?

  77. I’ve noticed on PC that enemies can spot you at night through walls and objects. Their light will be visible through solid walls and objects and if they look in your direction, they will spot you and start to attack, even tho there’s no way possible they could have seen you unless they have X-ray vision.

  78. Had that problem too, pc version. Did numerious things. What did help was restarting chapter with that save:

  79. My game for some reason didn't want to continue on the part where you have to run to the elevator to get out of the communication center in the desert place. I'm able to move and do everything else but the elevator won't open and the pack of spiders don't spawn. Can anyone help?

  80. Playing on PC, For some reason I get launched FAR away from the train when trying to leave Artyom's train compartment. This happens exactly after the conversation with Anna

  81. I got a bug on the PS4 version. While playing on the Caspian Sea, I was looking for Anna to do the slaves sidequest, but when I encounter her she is bugged with an invisible rifle and won't talk or move. Tried to reload the game a few times with no luck, I also tried to wait a few minutes but that didn't work either.

  82. im playing on ps4 and suddenly i can no longer aim down sights, when i try my character just lifts his gun up

  83. I am playing on a PC with an RTX2080, I found that the railcar disappeared after clearing out the bandit camp. I am currently wandering around trying to find it.

  84. Anybody else encountering the glitch in the dead city on xbox one where is refuses to let u exit the car at the dead end? I've tried everything, switching weapon loadouts beforehand. Driving the car slower. Stopping at different angles. I can't get past this part

  85. I'm really hoping someone else is experiencing this. On Xbox One X, I have run into a continuous issue where I can shoot enemies and receive hit markers, but they don't take damage. In addition, they don't actually register me at all. Example: at the outset of "The Taiga", I'm able to put arrow after arrow into the initial wolf, run around wildly, and the wolf does absolutely nothing. No damage is taken, it doesn't attack or run after me, so I'm just left standing there. Began happening towards the end of the desert missions. It makes the game literally unplayable, as I can't progress at all. PLEASE tell me someone else has encountered this.

  86. Xbox one player here, I'm dealing with a similar issue where none of my guns work on enemies except the air gun for some reason, and soon after that another bug where human enemies don't register the character. They are incapable of seeing me even when I'm in front of them. This all began early on in the desert missions.

  87. I have encountered a bug with Artyom's cabin door in the first part of the Summer level after the cutscene and when I try to open the door Artyom's hand clips into the door and I get launched FAR away from the train.

  88. Hi i made a reddit account just for this :). On Pc(Steam) in the dessert area in the way north mission area. I just completed the mission then fight the ambush back at the train. I return to norther mission area to search for more loot. some Invisible wall is put in behind me so i can get back and if i go through the cave again i cant crawl through to the water collection area. There is just no prompted to crawl at the end and i dont fit while crouched. I did many jumps trying to return the way i came but there is a clear boundary every where i can go.

  89. Hey guys, I got a bug on the PS4 where I no longer can see my arm or hand. This really throws off the immersion of the game. It’s also game braking because I’m invincible I can’t take damage from gunshots or melee attacks from the creatures. I got this bug shortly after leaving the Ark level and thought restarting the game would fix it but no such luck. Has anyone else gotten this bug?

  90. Playing on PS4 Pro. When trying to start the Baron's Fortress mission in Caspian level, when I get to the X on the map where I am supposed to meet Damir and Giul only Damir is there and will not speak or move from his spot on top of the train car. Giul is nowhere to be found and I am unable to get into the grate to start the mission. I have seen a lot of others experiencing this on YouTube as well under videos called Baron's Glitch.

  91. Just sent in a report about the flashlight (and NVG) not charging/working after the spider level in the Forest. I've tried everything and still cant get it to work. Really hope they fix this soon as it makes that level practically impossible and the flashlight is literally imperative to the gameplay, especially underground.

  92. Same here. I'm on PC. I have the same bug but in Novosibirsk after spider nest in forest level. You can't recharge the flashlight like in this video:

  93. Yeah, i got that problem too but in first episode. Im stop playing game 2 weeks ago and im waiting for patch. So, from yesterday we have a New Patch and he didint fix anything. Shame. Im playing on PS4 Pro too.

  94. Yup. Same. Ran around for like an hour, trying to figure out if I missed something or what - then the sun set and I could see her green laser sight scanning the ground from 20m up (also PC, i7, 2070, 16GB, Win 10, SSD).

  95. On PC, went back to the train after finding the map in Caspian and a sandstorm hit. Now I am stuck in the hut with Miller just repeating himself and no prompts or options to do anything. Saves are either an hour ago or 1 min ago.

  96. One of the lines you hear says to sit in the chair to report to the general. Do that. I was stuck here a few minutes before I figured that out.

  97. Ok, simply put on the PC version of Metro exodus the audio can cut out and actual game can freeze, when it's trying to load in the map (actual area). somtimes it's reasonable, why it's loading in the map somethimes, but when im in combat or simply walking into a room right next to me, the game would go potato texture and try and load in the room, which results in the audio cutting out, and the game, might freeze. Atfer the room would load in the game goes back to normal.

  98. Platform: PS4 (Patch 1.02 installed)Bug: Anna stops moving after encountering the first pack of mutants after coming up to check the radio for signals. Kills them, then just stops moving or talking. Teleports to my side further down the highway when the large pack runs by and a few stop to attack. Kills them, stops moving. Can't find a way to progress, assuming she needs to boost me up to a ledge. Reloading checkpoint didn't fix it. Restarting the entire game didn't fix it either.

  99. The first mission in Caspian Sea is gone. The marker straight gone for lighthouse mission where Damir already have my car. Will it be a problem? PC user here. Hope it does not effect the good ending.

Leave a Reply

Your email address will not be published. Required fields are marked *

News Reporter